Unable to upgrade Autodesk Desktop Connector via Microsoft SCCM due to CustomAction CleanNamespaceDLLS failing

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

You are trying to upgrade Autodesk Desktop Connector to a new version using Microsoft Endpoint Configuration Manager (formerly known as System Center Configuration Manager or SCCM), however the deployment fails to install. 
 

Causes:

Inspecting the file CDX_2017_install.log an error similar to below can be found:
Calling custom action CustomActions!CustomActions.CustomActions.CustomAction_CleanNamespaceDLLS
Killing explorer: 21288
Exception caught: Zugriff verweigert
   bei System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited)
   bei System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited)
   bei System.Diagnostics.Process.Kill()
   bei CustomActions.CustomActions.CustomAction_CleanNamespaceDLLS(Session session)
CustomAction CleanNamespaceDLLSCustomAction returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (84:64) [11:12:51:635]: PROPERTY CHANGE: Deleting UpdateStarted property. Its current value is '1'.
Action ended 11:12:51: InstallFinalize. Return value 3.
The issue is related to CustomAction_CleanNamespaceDLLS not able to terminate the process explorer.exe during the uninstall

Solution:

To solve the issue try the following one by one:
Note: You may need to consult with your System Administrator to implement the following suggestions.
  • Request the user closes all File Explorer windows before running the install via Software Center.
  • Run the install via admin user instead of System Account.
  • Modify your script to terminate explorer.exe before running the install, and to restart explorer.exe after the install is complete. Make sure the script terminates and restarts the process for all users (not just the installing user).

Products:

Desktop Connector;


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