Unable to view Revit cloud models in Revit when clicking "External Resource" to insert a link

Autodesk Support

Feb 25, 2025


Products and versions covered


Issue:

  • Users reported that when trying to link a BIM 360 / ACC hosted Revit model through the "External Resource" in Revit, some or all RVT models are missing.
Screen of External Resources button
  • Files appear as 'Not Found' under Manage Links.

Causes:

The following reasons could cause this issue:

  • The missing RVT files were not initiated to the cloud project through Revit.
  • The missing RVT file is a copied version of the cloud model in a different folder.
  • The missing RVT file is in a different cloud project than the host model that is open.
  • Certain add-ons or other components of the environment are conflicting with Revit.

Solution:

Interactive guidelines for troubleshooting

Troubleshooting BIM 360 and Autodesk Construction Cloud model access from Revit

Manual troubleshooting

Update Revit

 Update your software

Cloud Model

Make sure that the model was initiated to the cloud from Revit. To allow the model to appear in the (External Resource) link dialog box, open the model and then upload it to the cloud through Revit.

Model in a different cloud project

The following article has different options depending on the version of Revit and what kind of projects are used:

How to link Revit cloud models between different cloud (BIM 360/ACC) projects.

Desktop Connector

Use Desktop Connector to link the Revit models hosted on BIM 360 for nonworkshared models.

  1. Install Desktop Connector.
  2. Open the work shared host model in Revit. 
  3. From Manage Links, add a link: "Manage tab > Manage links >Add".
  4. Click "Desktop" as the start location for browsing, then navigate to the "Autodesk Docs". (When using Desktop Connector 15.8 or older, start location should be "My Computer".)

Note: Linking RVT files through the Desktop Connector is not a recommended workflow and should be avoided when possible.

Disable add-ons in Revit

Test disabling all add-ons used in Revit to see if the issue is caused by one or more add-ons conflicting with Revit. 

Folder Permissions

To link a model in Revit, "View+Download" permissions are required to the folder where model are hosted on the cloud.

Check the Revit environment for conflicting components:

  • Windows Updates.
  • Antivirus/ Network Security Services.
  • Windows User Account - The 100% safe way to rule that out would be to test the program behavior on the affected machine with the Hidden Windows Administrator Account. (If that does not reproduce the behavior, start looking at what happens when creating a new local Windows Account for the affected user versus regenerating the Windows Domain User Account.)

Products:

Revit; Revit Cloud Worksharing; BIM 360; Construction Cloud;


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