Unexpected behavior in Revit due to elements with no workset assigned

Autodesk Support

Jun 17, 2024


Products and versions covered


Issue:

When working in Revit, certain operations are blocked, give errors or crashes in a specific workshared Revit model.

The following line is recorded in the Revit journal around the time of the issue:
DBG_WARN: element ######## does not have PartitionId assigned: line 926 of Partitions\PartitionTable.cpp.
 

Causes:

  • When worksharing is enabled for a model, Revit expects that every element will have a workset assigned.
  • There are one or more elements in the model without a workset assigned.

Solution:

Update Revit

See the following article for information on How to keep Revit updated.

Delete Element(s)

If the issue continues when the latest update is applied to Revit, go through the following steps to delete the elements without a workset assigned:
  1. Open the model in Revit with the Audit box checked.
  2. Select the element using the element ID from the journal entry.
  3. Check if Unpin command is available, and if it is unpin the element
  4. Delete the selected element.
  5. If the issue continues, check the journal again for new elements, and go through the steps again to delete.

Disable Worksharing

If deleting the element is not working, go through the following steps to disable worksharing, and then re-enable:
  1. If working with network/cloud based model, save the model to your local system (Save As).
  2. Open the model using the Detach from Central option.
  3. When prompted, select to Discard Worksets (This will remove user created worksets along with the automatically created ones).
  4. Save and close the model.
  5. Open the model again, enable worksharing, and save central model.
Note: If using cloud based worksharing (or Revit Server Enterprise), links to the model will need to be updated in other models linking to this one.

Products:

Revit;


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