Repairing, Uninstalling and Reinstalling the Vault Server software

Autodesk Support

May 14, 2024


Products and versions covered


Issue:

You are looking for steps to repair, uninstall or reinstall Vault Server.

Causes:

The software is behaving inconsistently and you suspect that program files or components used by Vault have become corrupted.

Solution:

IMPORTANT

Uninstalling Vault Server will not remove vault data. If Vault Server is uninstalled, the SQL server directory and file stores will remain intact. However, Autodesk strongly recommends backing up all databases and necessary files prior to making any changes to the installation of Vault Server. If you are not able to run the Vault backup, take an emergency backup.

How To... Create an Emergency Vault Backup


Scroll down to the following sections:-

Try Repair First.
If Repair doesn't help, Uninstall and Reinstall.
If Uninstall and Reinstall doesn't help, Uninstall Vault Server, remove IIS (using a script), then reinstall IIS (using a script) and reinstall Vault Server.
Reluctant to uninstall Vault Server?
If that does not resolve the issue, you will need to uninstall Vault Server and ALL the components that it uses.

 

Try Repair First

1) Press the Windows logo key+R keys on your keyboard.
Type "appwiz.cpl"
 
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2) Locate "Vault Basic,or Workgroup or Professional (Server)", right click and select Uninstall\Change.
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3) Click the "Repair or Reinstall" button.
 
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4) With "Repair" as the selection, click the "Repair" button again
 
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If the Repair did not resolve the issue, follow the steps below
 

If Repair doesn't help, Uninstall and Reinstall

 
Repeat steps 1) and 2) above

A) Click the "Uninstall" button.
 
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B) Click the "Uninstall" button a second time.
 
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C) Once the Server software is uninstalled, reinstall it from the installation media.


If Uninstall and Reinstall don't help, Uninstall Vault Server, remove IIS (using a script), then reinstall IIS (using a script) and reinstall Vault Server.
 

How to manually remove IIS and reinstall it using Powershell Scripts



If that does not resolve the issue, you will need to uninstall Vault Server and ALL the components that it uses. The list of components that are used, can vary with every release and edition of Vault Server. The list of components for each version is maintained here:

Components installed by Autodesk Vault (Server and Client)

 

Reluctant to uninstall Vault Server?


From a troubleshooting perspective, many issues can be resolved quickly and, provided the necessary precautions are taken (such as having a restorable backup), can be rectified with minimum risk by uninstalling and reinstalling some or ALL of the components used on a Vault Server.

Consider that Uninstalling and Reinstalling the Vault Server application itself (and all the components used, including IIS), will...
  • NOT delete databases nor Filestores.
  • Does not remove Workgroup replication
  • Will take less than 15 minutes.
  • Be less likely to incur time-consuming errors.
  • Have a higher chance of success.
  • is supported by Autodesk.
Uninstalling and reinstalling Vault Server is quick and simple in comparison to searching for a manual reconfiguration of a specific component.
Tweaking IIS and SQL in ways that are not documented in Vaults online help are untested by development, could have unexpected consequences, and should only be used as a last resort.

After any reinstall, ensure that the latest available updates are applied to the client and the server. (Vault Downloads)

If the above reasons are not compelling enough to perform a full uninstall and reinstall of Vault Server, IIS and the other components, please log a support case with Autodesk, who will need to understand why a manual reconfiguration is a better option. This information can then be fed back to our development team to improve the product.

Products:

Vault Basic; Vault Professional; Vault Workgroup;


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