When running Dynamo a blank screen appears on the start window preview and the Dynamo icon gets dimmed in Revit

Autodesk Support

Oct 30, 2024


Products and versions covered


Issue:

  • After opening Dynamo for Revit, only a blank screen appears on the start window preview and the Dynamo dialog box is not visible/ is not working.
Image of blank screen appears on the start window preview of Dynamo in Revit
  • Also, the Dynamo icon in the Revit ribbon is dimmed and indicates that the program has started.
Image of Dynamo icon grayed out in Revit
 

Causes:

The blank screen is due to the Dynamo window appearing off-screen (for example, after changing display resolution, presenting/connecting another display).
The graphics card on the affected workstation must then recalculate the content displayed in the Dynamo window, but this recalculation must be started manually.

Solution:

To solve this issue, try one of the following options:

  • Turn off the monitor and turn it back on to reset the graphics.

  • Restart Revit and click the Dynamo icon, or if the Dynamo window preview with a white background is already open, select it and use the following key combination:

  1. Press together: alt + space + m.
  2. Press any arrow key on the keyboard.
  3. Move the cursor to the main screen.
  • Right-click on the Revit Dynamo window in the Windows Taskbar and toggle the Minimize/Maximize button of the Dynamo Window.

When using Dynamo on a machine with a two-monitor configuration, use one of the following solutions:

  • Plug in the second monitor and move the Dynamo window to the first monitor.

  • Maximize the Dynamo Window:

Image of maximizing the Dynamo window in the taskbar
 

Products:

Revit; Dynamo;


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