"Your local file is not compatible with the central model" appears in Revit

Autodesk Support

Sep 11, 2024


Products and versions covered


Issue:

When trying to synchronize or reload a link in a Revit, the following message appears:

 

Local File Incompatible with Central Model

Your local file is not compatible with the central model.
Error message. Your local file is not compatible with the central model.

Note: The file could be worked on without issue before synchronizing.

Causes:

Potential causes for this issue:

  • An upgrade to a newer version of Revit.
  • The central was substituted with an unrelated model using the same name.
  • The central model was restored from a previous version.
  • Two project members with the same username.
  • Someone is working directly in the central model.
  • File-based worksharing over a wide area network (WAN) / Internet / VPN connection, with a greater latency than would normally be seen on a LAN (0-2ms).
  • Not sufficient proxy and antivirus settings.
  • Some project members are pathed to the central model using a mapped letter drive, while others are mapped through the network path.
  • The local version of the central model is corrupted and was not synced for loner time.

Solution:

Cloud Based Models

If encountering this error with a cloud based model (BIM 360 Document Management / Autodesk Docs) see the following article for troubleshooting: "Your local file is not compatible with the central model..." when opening a cloud workshared model in Revit

 

Non-Cloud Based Models

  • Create a new local model.
  • Ensure that all project members are using the same Revit version with updates installed.
  • Check if the Central file was substituted with an unrelated project using the same username.
  • In Revit Options in the application Menu, make sure that each member has a unique username.
  • Note:  The contract manager or software coordinator must assign products and services to individual members by their unique Autodesk accounts when using a Single-User license.

  • Make sure that nobody is working in the central file directly.
  • Set up / use Revit Cloud Worksharing rather than file-based worksharing over an Internet / VPN connection.
  • Verify that all project members are pathed to the central file in the same manner, for details check "The central model has been copied or moved" when creating a local model in Revit.
  • Make sure that the model is healthy, check the number of unused elements, and purge them. While noticing a high number of duplicated materials/assets, use the macro from the article to clean the model.

Products:

Revit;


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