"Your local file is not compatible with the central model..." when opening a cloud workshared model in Revit

Autodesk Support

Mar 15, 2025


Products and versions covered


Issue:

When opening a cloud workshared model in Revit the following messages appear:

Local File Incompatible with Central Model

Your local file is not compatible with the central model.

This could be due to an upgrade to a newer version of Revit or because the central model was substituted with an unrelated model using the same name or because the central model was restored from a previous version. You must create a new local file and copy/paste any changes made to your original local file into the new model.
 

Compatibility messag appears when accessing the cloud model in Revit
 

Causes:

Beyond the causes listed in the error, the local model can become Incompatible with the central when there are two project members with the same username making changes to the model.

Solution:

Clear Error

If you want to save your local model (to copy/paste or compare against new local), save the model locally, and then close the model.
To clear the error, when opening the cloud model select the "Discard my changes..." option (this will create a new local).

Clear the collaboration cache

Follow the steps in the following article to recreate the collaboration and Cefcache: How to clear a corrupt/damaged cloud workshared model or outdated link from the system in Revit

Prevent Error

  • Synchronize the model before closing.
  • Check the username field on the General tab in the Options dialog to make sure that each project member has a unique username.

    Non-Cloud Model

    If seeing this error with a non-cloud based model (File-based / Revit Server based worksharing), see the following article for troubleshooting: "Your local file is not compatible with the central model" appears in Revit

    Products:

    Revit; Revit Cloud Worksharing; BIM 360; Construction Cloud;


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