AutoCAD freezes when importing a block into a drawing

Autodesk Support

Mar 5, 2025


Products and versions covered


Issue:

When opening the INSERT dialog box or importing a block into a drawing AutoCAD freezes and needs to be forced closed.

Causes:

  • The Windows temp folder is full.
  • Blocks are located at an unsupported location. 
  • The AutoCAD user profile is corrupted.

Solution:

Try the following steps and check whether the issue persists after each:

  • Clear the Windows Temp folder:
    1. Open Windows Explorer.
    2. Type %temp% on the address bar on top.
    3. Select files, make sure that important files are not selected.
    4. Delete the selected files.
  • Move all the blocks to a local or supported location. See Autodesk support for non-Microsoft networks.
  • Reset AutoCAD to Defaults. See How to reset AutoCAD to defaults.
  • Install the latest AutoCAD Version.

Products:

AutoCAD Products;


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