"ERROR: There were no plottable sheets in the current operation." when Publishing in background in AutoCAD Products

Autodesk Support

Feb 13, 2025


Products and versions covered


Issue:

Users reported that when publishing a PDF in background in AutoCAD, the following error is shown in Plot and Publish details:


ERROR: There were no plottable sheets in the current operation.
 
  • The PDF files might still be created but not contain all the expected sheets.
  • In some instances, the following messages might also be present:
    • WARNING: Incompatible or Missing Plot Style
    • ERROR: Device not found

Causes:

AutoCAD is installed alongside Civil 3D. 

Solution:

  1. Clear the Publish in background checkbox.
  2. Publish the PDFs again.
Publish

Alternatively:
  • Copy the custom Plot Styles to the default AutoCAD Plot Styles folder at:
C:\Users\>>your username<<\AppData\Roaming\Autodesk\AutoCAD 20xx\enu\Plotters\Plot Styles
  • Add the following path to AutoCAD Plot Style Table Search Path:
C:\Users\>>your username<<\AppData\Roaming\Autodesk\C3D 20xx\enu\Plotters\Plot Styles
 

Products:

AutoCAD Products;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support