"Error 1317. An error occurred while attempting to create the directory..." when installing Autodesk product, article contains multiple solutions

Autodesk Support

Feb 10, 2025


Products and versions covered


Issue:

When installing Autodesk product, it is stopped with one of the following errors : 

 

Error 1317. An error occurred while attempting to create the directory: C:\Users\Public\Documents\Autodesk

 

Error image from AutoCAD 2018 install

 

An error occurred while attempting to create the directory: C:\Program Files (x86)\Common Files\Autodesk Shared\Materials\2020\assetlibrary_base.fbm\Maps\Wood\mi.phenomenon


Error image from AutoCAD LT 2020 install
 

An error occurred while attempting to create the directory:
C:\User\Public\Documents\Autodesk\Fabrication 2023


Error image from Fabrication 2023 install

 
 

Causes:

  • Permissions or user profile issues.
  • Folder redirection.
  • Conflicting security software or policies (Controlled Folder Access).

Solution:

Permissions or user profile issues:

Refer to: What permissions are required for Autodesk software installation.

 

Folder redirection:

Refer to: "Error 1606. Could not access network location" when installing, uninstalling, or launching Autodesk product.

 

Conflicting security software or policies:

  • Refer to Autodesk Licensing Service: Known Conflicting Applications for a list of conflicting applications.
  • Disable Controlled folder access:
    1. Open Windows Defender Security Center.
    2. Click Virus & Threat Protection.
    3. Click Virus & Threat Protection settings.
    4. Scroll down to Controlled folder access and temporarily switch to the OFF position. 
Image from settings of Windows Defender
Note. The Controlled Folder Access can also be disabled from the registry key Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender\Policy Manager\EnableControlledFolderAccess changing the value from 1 (Enabled) to 2 (Disabled).


If the error still occurs try these additional steps:

  1. Create a new local admin user on the computer (follow these steps if you have Windows 11 or 10.) Use these steps for Windows 8 & 7.
  2. Retry the installation in the newly created local admin profile. 
  3. Verify that your Autodesk product launches and activates successfully.
  4. Switch back to your existing user profile and test to see if your Autodesk product is working as expected. If not, you may have a permissions-related issue or something wrong with the user profile.

Products:

All Desktop Products;


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