HSM or HSMWorks loss of access to software and required to update serial number

Autodesk Support

Jan 24, 2018


Products and versions covered


Issue:

Inventor or SolidWorks starts and HSM or HSMWorks will not load.  There is a message that states either:
  • Renew your license
  • Contact your administrator to request permission to use this product
  • Import Request Failed

Causes:

HSM was merged into the Product Design and Manufacturing Collection in 2017.  In some instances this has caused customers to be required to update their serial numbers to continue using the product.

Solution:

If your software user permissions change or your subscription expires you may receive an activation screen with one of the following messages:
  • Renew your license
  • Contact your administrator to request permission to use this product
  • Import Request Failed
If you have access to the Renew License Screen, follow these steps to update your serial number:
https://knowledge.autodesk.com/customer-service/account-management/manage-licensing/license-information/update-serial-number

If you’re a single user and you do not have access to the Renew License Screen, log into your Autodesk account at manage.autodesk.com.  You will need the email address and password of the user associated with the account to login to manage your account. 

When installing HSMWorks 2018, the default option is "Premium". If your license is "Ultimate", make sure to select "Ultimate". If you did not select the correct option during the installation you might receive the dialog box "Renew your license". Uninstall HSMWorks 2018 and reinstall. Make sure to select the correct option that matches your license.

HSM and HSMWorks are now part of the Product Design & Manufacturing Collection.  Be sure to click on Product Design & Manufacturing Collection to view HSM and HSMWorks serial number details.

If the product is already activated the serial number will be displayed.  If the product is not activate select Get Serial number next to the product that you would like to activate. Take note of that number and enter when required.

User-added image

Enter this serial number when prompted during activation:

User-added image

If you receive this message:

Contact your administrator to request permission to use this product

Then you are likely in a multi-user environment, in which case:

The administrator of your Autodesk account should login into the associated account and activate the appropriate user account per instructions in this article:

Managing Users & Permissions

Also, this article regarding access to your subscription software will provide guidance on managing the products and services in your account, as well as general access guidance and downloads to entitled software.

Access Your Subscription Software





 

Products:

Autodesk HSM;

Versions:

2018;


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