Multiple Autodesk AdskLicensingAgent.exe processes running in Task Manager

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

When running Autodesk software, multiple instances of the Autodesk AdskLicensingAgent.exe process appear in Task Manager, with high usage of the computer's resources.

Causes:

  • Outdated or Corrupted Autodesk Desktop Licensing Service.
  • In a network license environment, this can be caused by a mismatch between variable ADSKFLEX_LICENSE_FILE and AdskLicensing cached value for the license server. 

Solution:

To solve the issue, try the below solutions:
 

Update the Autodesk Desktop Licensing Service

See Autodesk Licensing Service download.


Inspect the license server values stored in the registry and AdskLicensing (network license only)

  1. Open an elevated Command Prompt (press WIN+R > type cmd > press CTRL+SHIFT+ENTER).
  2. Type and execute the command "C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\Current\helper\AdskLicensingInstHelper.exe" list
  3. Inspect the value for "lic_servers" of the affected product (below Maya 2022 as example):
image.png
  1. Open Windows registry (press WIN+R > type regedit > press CTRL+SHIFT+ENTER).
  2. Inspect the key HKEY_CURRENT_USER\SOFTWARE\FLEXlm License Manager\ADSKFLEX_LICENSE_FILE and make sure that the value matches:
image.png
  • If the value does not match (like below). Double-click the key and modify it.image.png

Alternatively, remove the ADSKFLEX_LICENSE_FILE variable. Upon next product launch, it will be recreated automatically based on the value stored in Autodesk Licensing Service.

Warning!
Problems caused by improperly editing the Windows registry could render your computer operating system unusable. Microsoft provides a wealth of critical information that you need to know about the registry in the Microsoft Knowledge Base. Use the Microsoft Registry Editor only at your own risk and only after backing up the registry as outlined for your operating system in the Microsoft article How to back up and restore the registry in Windows and in the related solution How to back up the system registry. Additional information about the registry is also contained in the Help topics in the Microsoft Registry Editor.

 

Clean the system for any potential corruption with the Autodesk Desktop Licensing Service

See How to perform a Clean Uninstall of Autodesk products on Windows.

Products:

All Desktop Products;

Versions:

2020; 2021; 2022; 2023;


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