The 'AdvanceSteel' workspace is missing and no other workspaces are available in Advance Steel

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

When opening Advance Steel, no ribbons and menus are displayed. Workspaces are not available and cannot be activated. When trying to load a workspace, there are no workspaces available to load.

Causes:

The workspace customization file is invalid. 
 

Solution:

Follow the steps below to fix the settings:
  1. Close any Advance Steel and AutoCAD sessions. 
  2. Back up any customized Advance Steel databases or files.
  3. Reset the Advance Steel settings to default:
    • Windows Start - Advance Steel 20XX - [Language] - Reset settings to default - Advance Steel 20XX
Note: When working with Advance Steel 2016 or 2017, there is no option to reset the settings to default. Go directly to the second part of this article.
  1. Start Advance Steel 20XX. Do not migrate any setting at this stage (this can be done later if needed).
  2. Check the available workspaces, ribbons and Advance Palettes.
If the issue with missing workspaces or ribbons persists, continue with the steps below:
  1. Open the following folder:
    • C:\ProgramData\Autodesk\Advance Steel 20XX\[ USA ]\Steel\
  2. Rename the "Support" folder (ex: Support_OLD)
  3. Go to the Control Panel - Uninstall a product -  search for Advance Steel 20XX
  4. Right-click and select Uninstall / Change
  5. Select the Repair / Reinstall option and then Repair
  6. Restart Advance Steel when the process is complete

Products:

Advance Steel;

Versions:

2017; 2016; 2019; 2018; 2021;


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