Error 2502 and 2503 when installing, uninstalling or launching Autodesk product

Autodesk Support

Dec 5, 2023


Products and versions covered


Issue:

When installing, uninstalling or launching Autodesk product, a message like the following appears referencing
 
Internal Error 2503

internal error 2503

Internal Error 2502

2502.png

Internal Error 2503

2503.png

 

Causes:

Permissions restrictions preventing the Microsoft installer service from working as intended. This error is generated by the Windows operating system and not the Autodesk installer.

Solution:

Verify that the program has been installed and runs without issue by right clicking on the affected program and selecting "Run as Administrator". If it runs as intended proceed to the steps below. 

If the program launches with errors even when run with administrator rights, the installation may be corrupted and a clean uninstall and reinstall would be required.

To resolve the issue, do the following:
  1. Navigate to File Explorer location: C:\Windows\TEMP
  2. Right click on the TEMP folder and select "Properties".
  3. Select the "Security" tab.
  4. Then select the "Add" button.
  5. In the "Enter the object names to select (examples):" table, put in (without quote marks) "EVERYONE".
  6. Then select the button "OK".
  7. Then in the "Group or user names:" location, select the button "Edit".
  8. For all Group and user names, allow "Full Control".
  9. Then select the button "Apply".
  10. Launch the product. 

Products:

All Desktop Products;


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