Date property is shown as noncompliant in Vault Client after migrating database to new version

Autodesk Support

Mar 25, 2024


Products and versions covered


Issue:

After updating to a new Vault (Server) Version some Date properties in the Vault Client (for example Original Create Date) show a non compliant Equivalence issue:
 
Compliant.png

Other symptoms:
  • Issue can occur on Inventor or AutoCAD DWG files and Word documents.
  • Due to the "Compliance" issue it is not possible to change the status with the message:
"Some properties do not match pre-defined criteria..."
  • The date format is mixed up. 
    • Example:
      • File property format: DD/MM/YYYY
      • Vault property format: MM/DD/YYYY
  • "Use Date only while updating properties" might be enabled in Vault Settings:
image.png
 

Causes:

  • After the migration to the new version, a "Reindex file properties" was run on the Vault Server with mismatching regional settings for date format on the Vault Server and Vault Clients.
  • Value stored in Vault doesn't match the value which is stored in file.

Solution:

  1. Try running Synchronize Properties from Actions menu in Vault Client to make matching values of affected property in Vault and file.
image.png
  1. Verify that the Windows regional date format settings on the Vault Server and Vault Clients are matching:
    1. Start the Windows Control Panel and then run "Regional Settings":
    2. Verify the settings on Long Date and Short Date
    3. The settings on both Vault Server and Vault clients need to be the same
  2. Adjust the time format.
  3. Perform Reindex properties on the Vault Server: Re-Indexing Properties in a Vault.

Products:

AutoCAD; Inventor; Vault Professional;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support