"ProtoCore.Exceptions" when launching Dynamo from the Manage tab in Revit

Autodesk Support

Jan 29, 2025


Products and versions covered


Issue:

When launching the Dynamo/ Dynamo script from Revit the following message is displayed and Dynamo does not start:

ProtoCore.Exceptions.CompilerInternalException: Exception of type 'ProtoCore.Exceptions.CompilerInternalException' was thrown.
   at ProtoCore.AssociativeEngine.Utils.IsGlobalScopeDirty(Executable exe)
   at ProtoScript.Runners.LiveRunner.ApplyUpdate()
   at ProtoScript.Runners.LiveRunner.CompileAndExecuteForDeltaExecution(String code)
   at ProtoScript.Runners.LiveRunner.ResetVMAndResyncGraph(IEnumerable'1libraries)
   at Dynamo.Engine.EngineController.OnLibraryLoaded()
   at Dynamo.Engine.EngineController..ctor(LibraryServices libraryServices, String geometryFactoryFileName, Boolean verboseLogging)
   at Dynamo.Models.DynamoModel.ResetEngineInternal()
   at Dynamo.Models.DynamoModel..ctor(IStartConfiguration config)
   at Dynamo.Applications.Models.RevitDynamoModel..ctor(IRevitStartConfiguration configuration)
   at Dynamo.Applications.Models.RevitDynamoModel.Start(IRevitStartConfiguration configuration)
   at Dynamo.Applications.DynamoRevit.InitializeCoreModel(DynamoRevitCommandData commandData)
   at Dynamo.Applications.DynamoRevit.ExecuteCommand(DynamoRevitCommandData commandData)


ProtoCore. Exception message in Revit while launching Dynamo 

 

Causes:

The following could be the probable causes:

  • Revit API conflict caused by an installed third-party add-on.
  • Windows Operating System recent updates.

Solution:

Try the following options to address the behavior:

Disable add-ons

  1. Disable all installed third-party add-ons: How to disable add-ons for Revit
  2. If the issue is resolved, restore the add-ons one by one to determine which is causing the issue.

Update Revit

Check whether Revit is updated with the latest build version.

Uninstall and Reinstall Revit

  1. Perform a clean reinstallation of Revit..
  2. After installation, verify the behavior by launching Dynamo from Manage.

Note: If the behavior was introduced after upgrading Windows, Investigate storage disk sector size greater than 4 KB.

Products:

Revit; Dynamo;


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