"Post processor Error - Broken connection" when post processing with pmoptz in PowerMill

Autodesk Support

Nov 4, 2024


Products and versions covered


Issue:

"Post processor Error - Broken connection" when post processing with pmoptz in PowerMill:
 

Information 
Note: License error: CLM Error #1 listing in the information form. 
Same issue with this error message - License error: CLM Error #13

Causes:

  • Current post processor software is not retrieved correctly in the background.
  • Incorrect settings within toolpath may cause post processing to fail. 
  • Postprocessor software has not been registered (COM Register). 

Solution:

Ensure that the post processor software is being correctly retrieved in the background

  • Run COM Register on the Windows search bar by clicking Make Manufacturing Post Processor Utility 20XX the current version.
User-added image
      

Check various settings within the toolpath form to find which one is causing post processing to fail

  • The best way to do this be to start with the least number of settings within the toolpath; and then add one at a time.
  • For Example: If you are doing a multi-axis toolpath; start without Toolpath Smoothing to see if this causes the issue.
Note:
Windows User Account Control (UAC) may be blocking communication between PowerMill and Post system, so attempt COM register with UAC set to "never notify" otherwise a reinstall as administrator is required with UAC set to "never notify".

Products:

PowerMill;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support