"Installation error An error occurred while preparing for installation" when installing or uninstalling Autodesk product

Autodesk Support

Feb 25, 2025


Products and versions covered


Issue:

While trying to install or uninstall Autodesk software using the New Install Experience (version 2022 and selected 2020/2021 software), the following message appears, and the installation or uninstallation fails.


Installation error

An error occurred while preparing for installation.
Please exit and start the install again.
 

Installation error An error occurred while preparing for installation. Please exit and start the install again.
 

Environment:

Windows.

Causes:

  • Corrupted ODIS component installed on the system.
  • Antivirus on the system is preventing the installation from running properly.
  • Incorrect path in the deployment BAT file. 
  • Incomplete file download of 2022 products.

Solution:

Uninstall and Reinstall the ODIS component 

  1. Go to C:\Program Files\Autodesk\AdODIS\V1.
  2. Run RemoveODIS.exe as administrator.
  3. Download and install the latest version of ODIS.
  4. Run the product installer/uninstaller again.


Single install

  • Try a new installation after temporarily disabling or uninstalling any antivirus running on your system.
  • Redownload the software before attempting a new installation:
  1. Access your Autodesk Account.
  2. Download the software using "Download or Custom Install".
  3. Run the installer.


Custom Install or deployment

  • Verify the path.
  1. Navigate to the main image folder.
  2. Open the .bat file in Notepad.
  3. Ensure the path used is correct. Note: Use absolute path instead of drive letters. (For example, \\ServerName\Path\).
  • Move the deployment image locally or to another location and try again to install it.


During Uninstall 

Make sure you have uninstalled and reinstalled the ODIS component as per the first suggestion.
If this doesn't work, use the Microsoft Fix It tool to remove the software.

Products:

All Desktop Products;


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