"Disconnecting sync roots...." message appears frequently while using Autodesk Desktop Connector

Autodesk Support

Apr 7, 2025


Products and versions covered


Issue:

Users reported that Desktop Connector crashes and restarts repeatedly, displaying the message 'Disconnecting sync roots...' along with a command prompt running simultaneously with the message similar as shown below:

 

Waiting for process to exit: DesktopConnector.Applications.Tray
Done 

Disconnecting sync roots 

No sync roots identified 

Completed disconnecting sync roots


 Disconnecting sync roots error message in desktop connector    

Causes:

A Virtual Private Network (VPN) may be causing a conflict.

Solution:

To resolve the issue, verify the suggestions below:

Disable VPN 

Disable the VPN and try to launch Desktop Connector again.

Reset DC folders

  1. Rename the C:\Users\username\DC\ACCDocs\ folder to something like C:\Users\<username>\DC\ACCDocs Backup\ to create a backup version of the local cache.

  2. Open Windows Registry and delete registry keys that start with "DesktopConnector" from the following registry locations:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\SyncRootManager

    • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace

  3. Run "C:\Program Files\Autodesk\Desktop Connector\Reset\ResetDesktopConnector.exe".

  4. Launch Desktop Connector.

  5. All projects will need to be reselected using the "Select Projects" command from the Home Screen.

Install Latest Identity Manager

  1. Uninstall Identity Manager
  2. Delete these folders - "%LOCALAPPDATA%\Autodesk\Identity Services" and "%ProgramData%\Autodesk\IDSDK"
  3. Install latest Identity Manager

Products:

Desktop Connector;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support