Error: "Licensing System Error 20" when launching Revit

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

When running Revit the following error appears: "Licensing System Error 20"

"Licensing System Error 20"

User-added image

Causes:

  • Trusted Storage files are corrupted
  • C++ installation are corrupt
  • Revit installation is corrupt

Solution:

Try to change / reset license information by following the article below: After the steps above, delete the licensing information stored in the system doing the following:
  • Close any running Autodesk programs.
  • Sign out and Exit from Autodesk Desktop App and A360.
  • Go to C:\ProgramData\Autodesk\ and delete the ADUT folder
  • Go to C:\Users\<user>\AppData\Roaming\Autodesk\ and delete the ADUT folder
  • Delete the 3 files that begins with the adskflex in C:\ProgramData\FLEXnet. (Note Files could be hidden)
  • Delete the file LoginState.xml in %LOCALAPPDATA%\Autodesk\Web Services
  • Restart the software - repeat the activation process
Next try uninstalling and reinstalling all the Microsoft C++s
How to remove and reinstall Microsoft Visual C++ Runtime Libraries

If this does not solve the issue, try performing a clean uninstall, removing all the Autodesk software from "Products and Features" section of the Control Panel and all the Autodesk files/folders described the article below:

Products:

Revit Product Family;

Versions:

2017; 2019; 2018;


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