Model processing hangs indefinitely within Design Collaboration in BIM 360 for Government

Autodesk Support

Mar 28, 2025


Products and versions covered


Issue:

Model processing is hanging indefinitely within the BIM 360 Design Collaboration module of the Autodesk for Government platform. This behavior occurs after updating a Revit Cloud Workshared model belonging to a BIM 360 Design team, including with the "Update to latest" button from the Design Collaboration module.

Within the Design Collaboration module

  • The model may show it has been processing for over a day, with no change to the completion percentage.
  • It is still possible to share and consume packages that contain the model. 
  • There is no error returned. The spinner icon simply appears to show indefinitely. This spinner may also be noted next to the Project Model icon on the team home page. Hovering over the spinner circle, it notes, "The following model is still being processed: FileName.rvt.

Within the Document Management module

  • The model completes publishing at 100%. 
  • There is no error or broken file icon.
  • The model can be opened and viewed successfully.

Causes:

The model is large or complex.

The overall size of the model could be attributed to a combination of factors that include:

  • Large number of links loaded into the model
  • Large number of 3D views
  • Overall number of elements within the model
  • Corrupted views or elements within the model 

The amount of data directly impacts the amount of time that it can take to process within Design Collaboration. Large amounts of data can then cause the processing to time out. 

Solution:

There are multiple potential solutions.

Confirm that the model will open in Revit

  1. Test opening the model in Revit
  2. Watch for errors/warnings, that prevents the model from opening. For example: "Can't load link BIM 360 due to errors" displayed when trying to open cloud workshared model with links in Revit
  3. After clearing issues with the model encountered when opening, synchronize the model.
  4. Check if the processing completes in the Design Collaboration module.

Republish the model

If there are no errors encountered when opening the model or clearing these warnings and synchronizing doesn't allow the processing to finish, follow the steps below:

  1. Make a minor change to the model in Revit. 
  2. Save and sync the change in Revit. 
  3. Publish the change through Revit Cloud Worksharing, following the normal process (as outlined in this article: Publish Cloud Models).
  4. Confirm the model as been successfully updated in BIM 360 Document Management and can be viewed there. 
  5. Navigate into the correct Team space within BIM 360 Design Collaboration and click, "Update to latest."
  6. Also: If republishing gives the same result, try to republish but including only a single 3D view. If it works, try to include the Sheets and Views gradually until you find one that produces the error. 

Note: Model publishing times may be longer than expected. See this help article for tips on decreasing publishing time: Cloud workshared model in Revit takes a long time to publish to BIM 360.

Identify the corrupted elements in Revit

To identify the elements that cause a slow BIM 360 performance, follow the steps below:

  1. Go to BIM 360 Document Management.
  2. Navigate to the Revit model location.
  3. Open the affected Revit model.
  4. Switch to 3D view.
  5. Identify the elements that cause a slow geometry regeneration.
  6. Open the Revit model.
  7. Remove the identified families from the Project Browser.


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