"Revit cannot run the external application..." when opening Revit

Autodesk Support

Apr 11, 2025


Products and versions covered


Issue:

When opening Revit, the following message appears:

External Tools - External Tool Failure

Revit cannot run the external application <Application name>. Contact the provider for assistance. Information they provided to Revit about their identity: <information>

Revit cannot run the external application <Application name>. Contact the provider for assistance. Information they provided to Revit about their identity: <information>"

 

  • The journal shows lines similar to the following:

TaskDialog "Revit cannot run the external application "application name". Contact the provider for assistance.  Information they provided to Revit about their identity: "applicationname."
'Id : TaskDialog_External_Tools_External_Tool_Failure

 

Causes:

An add-on installed in Revit cannot be loaded.

Solution:

Disable add-on

  1. See the following article for information on How to disable add-ons for Revit.

  2. If you are not finding the add-on based on the name from the error, disable all add-ons, and confirm that the warning is cleared. Then re-enable them to find the one causing the warning.

  3. If you don't need the add-on, you can leave it disabled or uninstall through the Apps & Features (in Windows Settings).

  4. If you do need the add-on, uninstall through the Apps & Features (in Windows Settings), then reinstall the latest version of the add-on and retry.

  5. If the warning continues after reinstalling the latest version of the add-on, check with the maker of the add-on for further troubleshooting.

    1. It would be good to check that Revit is updated (in case the add-on needs something in the latest Revit update): How to keep Revit updated

User.config

If the warning lists an exception that references the user.config similar to the following:
System.Configuration.ConfigurationErrorsException:'.', hexadecimal value 0x00, is an invalid character. Line 5, position 1.
(C:\Users\<USERNAME>\AppData\Local\Autodesk,_Inc.\DefaultDomain_Path_<xxxxxxxx>\<revitbuildnumber>\user.config line 5) ---->System.XML.XMLException

Error details "System.Configuration.ConfigurationErrorsException"

Go through the steps in the following article to reset the user.config file: Crash occurs when trying to open any cloud model in Revit.

 

      Products:

      Revit Product Family;


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