Slowness while saving an AutoCAD Products drawing to a network location

Autodesk Support

Mar 26, 2025


Products and versions covered


Issue:

When saving a drawing in AutoCAD Products (e.g. AutoCAD, Civil 3D, etc.) to a shared location or to a network drive, the process takes a long time to finish.

Causes:

  • Slow network connection.
  • Corruption or excess content in the drawing files.
  • Tool palettes are shared in the network drive where all users have write access.
  • Corrupt AutoCAD settings migrated from a prior version.
  • Unused or corrupted Xref

Solution:

Do one or more of the following:

Products:

AutoCAD for Mac; AutoCAD LT for Mac; AutoCAD Products;


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