"The feature you are trying to use is on a network resource that is unavailable." due to missing RVT.msi when Installing or Uninstalling of Revit 2021.1.2 or later Hotfix

Autodesk Support

Nov 19, 2024


Products and versions covered


Issue:

When trying to install or uninstall the Revit 2021.1.2 or later Hotfix, the installer requires the RVT.msi file from the original install source. The following window is then shown:

 

Revit 2021

The feature you are trying to use is on a network resource that is unavailable. 
Click OK to try again, or enter an alternate path to a folder containing the installation package 'RVT.msi' in the box below.


Environment:

Windows

Causes:

If Revit 2021 installation files have been modified, the installation of Revit updates/hotfixes may prompt users for the RVT.msi file from the original install media. This process cannot be skipped.

Solution:

Follow these steps to remediate the issue, depending on your scenario:

Single installation

  1. Open Windows Registry Editor (Press Win+R, type regedit, press ENTER).
  1. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\UPI2\{7346B4A0-2100-0510-0000-705C0D862004}.
  2. On the right pane, check the BuildNumber value to identify which version of Revit installer was used to install Revit 2021 on your system. Below a list for reference:
    • If the BuildNumber is 21.0.0.383, then the Revit 2021 installer was used.
    • If the BuildNumber is 21.1.1.109, then the Revit 2021.1 installer was used.
    • If the BuildNumber is 21.1.11.27, then the Revit 2021.1.1 installer was used.
    • If the BuildNumber is 21.1.21.45, then the Revit 2021.1.2 installer was used.
  1. Download the original install media which corresponds to the version of the installer previously identified. Download links are available below. Note: Each installer is divided into six parts.
    • Revit 2021.1.2 - Part 1 - 2 - 3 - 4 - 5 - 6
    • Revit 2021.1.1 - Part 1 - 2 - 3 - 4 - 5 - 6
    • Revit 2021.1 - Part 1 - 2 - 3 - 4 - 5 - 6  
    • Revit 2021 - Part 1 - 2 - 3 - 4 - 5 - 6
  2. Once the download is complete, double-click on any one of the packages to start the extraction. You will be asked for a location where the extracted files will be saved. Pick one of your choice.
  3. Once the extraction is complete, navigate to the location where the files were extracted to, e.g. default path is C:\Autodesk\.
Note: The specific Revit 2021 folder name can change depending on the installer used for extraction. For example, if the installer parts were named Revit_2021_r2_G1_Win_64bit_dlm_xxx_xxx.sfx.exe then the default path will be C:\Autodesk\Revit_2021_r2_G1_Win_64bit_dlm.
  1. Navigate to \x64\RVT\ and find the RVT.msi file.
  2. While holding the SHIFT key, right-click the RVT.msi. Then click Copy as path
  3. Return to the dialog asking for RVT.msi or, run the install/uninstall of Revit 2021.1.2 Hotfix again, if it was previously closed.
  4. When the dialog looking for the RVT.msi appears, paste the path pointing to the RVT.msi you just copied in step 8. Then click OK to continue with the uninstall process.
  1. The install/uninstall will complete as expected.


Multiple installations

Note: The intended audience for below steps are system or IT administrators. Consult with your system/IT administrator to implement the below suggestions.
  1. On a machine where the issue occurs, enable Windows Installer logging, see Enable Windows Installer logging.
  2. Download the specific Revit 2021.1.x update.
  3. Extract the update. E.g. for 2021.1.4 this is:
/path/to/Revit_2021_1_3.exe /e /path/to/2021.1.3
  1. Navigate to /path/to/2021.1.3/ExtractFiles.
  2. Launch each msi/msp package individually until the issue occurs.
  3. Navigate to the machine's TEMP folder (Press Win > type %TEMP%, press ENTER).
  4. Find the MSIXXX.log correspondent to the last run msi/msp package.
  5. Look for the string "Existing file is unversioned and unmodified".
  6. Note down the file(s) where the mismatch occurs. 
  7. Starting from a fresh installation of Revit 2021 original release (RTM), collect the above files.
  8. Distribute these files to the machines where the issue is occurring with your preferred method (e.g. SCCM).
  9. Run the install/uninstall of the Revit 2021 hotfix. The expected files will be detected by the installer and the process will complete successfully.

Products:

Revit Product Family;

Versions:

2021; 2022; 2023;


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