"acad.pat file not found" when selecting the Settings option for Hatch

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

When trying to hatch something, it displays a solid hatch but nothing is displayed once the command is ended. No patterns are visible during the hatch command. 

When trying to generate a new hatch, and select the Settings options in the Hatch command, AutoCAD displays an error:
"acad.pat" Can't find file.
 
User-added image

Causes:

  • The folder where the .PAT file resides is not listed in Support File Search Paths within the Files tab of the Options dialog.

User Support Folder

The above example is for AutoCAD LT 2018. Specific product will determine the folder path from the Autodesk folder onward.

  • If the Support folder path is listed correctly, it could also be that the pattern (.PAT) file is missing from the Support folder.

Solution:

  • The default location for the acad.pat/acadlt.pat file is:
C:\Users\<username>\AppData\Roaming\Autodesk\AutoCAD 20xx\RXX.X\enu\Support\  (where the X represents values that vary by product)

If this folder is not shown in the Support File Search Path section, on the Files tab of Options, use the Add and Browse buttons to add it, then move it to the top of the list with the Move Up button.
  • Check that the file size is not zero (it should be ~16kb).
  • If the file is there, and seems correct, the AutoCAD profile might be corrupt. Try resetting the settings to default: How to reset AutoCAD to defaults
  • If the (.PAT) file is missing from the Support folder, check the UserDataCache folder to obtain a copy of it. The default location is C:\Program Files\Autodesk\AutoCAD 20xx\en-us\support. Copy both the acad.pat and acadiso.pat files into the user's roaming AutoCAD support directory. For AutoCAD LT, the file names are acadlt.pat and acadltiso.pat. Note that the UserDataCache folder is a hidden directory, so be sure that Windows is configured to display hidden files/folders.

Products:

AutoCAD Products;


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