Plotting to PDF from AutoCAD results in an error in Acrobat Reader

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

When plotting or exporting certain drawings to PDF from AutoCAD, and then opening it in Adobe Acrobat/Reader, one of the following messages is displayed:
 
Adobe Acrobat
Adobe Acrobat has encountered an unknown error.

User-added image

Acrobat Reader
Cannot find or create the font '[font name]'. Some characters may not display or print correctly. 

User-added image

Portions of the PDF drawing may be missing and not displayed.

Causes:

  • The PDF file format doesn’t recognize SHX text. When drawings with SHX fonts are plotted to PDF, the PDF stores that data as geometry (not text), so the SHX text is imported as geometry.
  • A font in the drawing cannot be found or created.

Solution:

Do one or more the following:

This issue is solved by AutoCAD Update 2020.1.3 and in newer versions. 
If you still run into this issue try one of the following:
  • Open the PDF in another PDF viewer, such as Foxit Reader instead of using Adobe.
  • Try a different PDF driver.
    • Use one of the built-in "AutoCAD PDF" drivers to create the PDF instead of a third-party PDF driver.
    • Plot the PDF using a third-party PDF printer.
  • Use DWG TrueView to create the PDF (see Where to download previous versions of DWG TrueView).

  • Use TrueType fonts instead of SHX fonts in the drawing. TrueType fonts are rendered as text objects in the PDF (see the video SHX fonts vs True Type Fonts).

Products:

AutoCAD Products;


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