AutoCADで長いファイル名でPDFを保存するときにエラーが発生しました

Autodesk Support

2023年10月8日


対象となる製品とバージョン


問題:

AutoCAD製品でPDFを生成すると、次の内容を示すメッセージが表示されます。

"AutoCAD Error
C:\User\<ユーザ名>\AppData\Roaming\Autodesk\AutoCAD 201x\enu\Plotters\PMP Files\.pmp" ファイルの保存中にエラーが発生しました

例:

ユーザが追加したイメージ

使用しているAutoCAD製品とリリース(年)によって、正確なパスは異なります。

また、PDFに出力する場合、イメージが部分的にしか出力されない問題もあります。

環境:


原因:

エラーメッセージに表示される完全なファイルパスが、Windows 255の制限を超えています。

解決策:

PDFの作成に関連するPC3ファイルを探して削除します。これはPlottersフォルダにあります。また、エラーメッセージに表示されているPMPファイルを探して削除します(存在する場合)。PMPフォルダ内のPMPフォルダに配置されます。そのようなファイルが存在しない場合は、実行しようとしている印刷ジョブのPC3ファイルと一致するPMPファイルを削除します。

削除したファイルを次の場所にあるファイルに置き換えます。

C:\Program Files\Autodesk\AutoCAD 201x\UserDataCache\Plotters

今後は、PDF PC3ファイルに対する変更を保存するよう求めるプロンプトが表示されたら、推奨ファイル名を受け入れるのではなく、既存のファイル名を上書きします。これにより、ファイル名が毎回長くなり、長くなるとエラーが発生します。

また、ページ設定で選択したPC3内で定義されていない用紙サイズが使用されている場合は、AutoCAD PDF PC3へのパブリッシュや印刷を行うことに注意してください。これは、前のページ設定が独自のカスタム用紙サイズまたは非標準の用紙サイズを持つ別のプリンタを指している場合に発生することがあります。用紙サイズの一貫性を保つため、印刷またはパブリッシュ操作ごとに新しいPMPファイルが作成され、多数の新しいPMPファイルが作成されます。ファイル名にはそれぞれ1つ以上の「A」が付けられ、文字が多すぎる問題が発生します。この問題は、PDF PC3ファイルを編集し、可能であれば同じ名前を使用して目的の用紙サイズを追加することで回避できます。または、そのPC3ファイルを使用する名前の付いたページ設定を作成し、新しい用紙サイズを選択して、その新しいページ設定を後続の印刷およびパブリッシュジョブに適用します。

イメージが印刷されない問題

関連項目:


製品:

AutoCAD 製品;


この情報は役に立ちましたか?


サポートが必要な場合は、Autodesk Assistant にお問い合わせください!

Assistant が回答を見つけたり、担当者に連絡するお手伝いをします。


オートデスクではどのようなサポートが提供されますか?

ご利用可能なサポートの種類は、サブスクリプションのプランによって異なります。現在のプランでご利用可能なサポート レベルをご確認ください。

サポート レベルを確認