AutoCAD のメニューとパレットで文字の尺度や表示が正しくない。またはダイアログが表示されない

Autodesk Support

2025年3月14日


対象となる製品とバージョン


問題:

AutoCAD 製品のリボン、メニュー、ダイアログ ウィンドウ、パレットの文字が予想よりも大きく表示され、多くの場合、フィールドが空白になったり、他の要素が見えなくなってしまいます。

原因:

  • 高解像度の画面を使用すると、アプリケーション内やオペレーティングシステム内のアイコンやメニューなどが小さくなります。
  • この表示を補正するには、Windows の[ディスプレイ設定]で画面のスケーリングの値を大きくします(Windows 10 では、既定でスケーリングの値が大きくなります)。
  • 画面のスケーリングに合わせるように作成されていないプログラムでは、ユーザ インタフェース(UI)要素が歪んだり、不釣り合いになります。
  • その最も大きな影響として、UI の文字が表示されるべき場所に表示されなくなります。
  • 文字が正しいサイズで表示されず、他の UI とのバランスが崩れて見えることがあります。文字がまったく収まらないほど拡大されてしまうこともあります。
  • AutoCAD バージョン 2017 以前、および一部の最新の AutoCAD 業種別製品(リリース 2018 および 2019)は、画面のスケーリングに合わせるように作成されていません。2,000 dpi 未満の画面解像度に最適化されています。
  • AutoCAD 2018 以降(すべての AutoCAD 製品)のすべてのコア UI 機能は、画面のスケーリングに対応しています。AutoCAD 業種別製品(AutoCAD Map 3D、Plant 3D、Civil 3D など)に固有の機能では、尺度が正しく調整されない場合があります。
  • 4K モニタを使用していて、グラフィックス ドライバの破損により Windows OS の解像度とスケールを調整できない場合。
  • モニタ画面スケールが 150% に設定されている場合。

解決策:

Windows 10 または 11 の場合

  • 画面のスケーリングを 100% に変更する:
    1. [スタート]メニューで「ディスプレイ」(または「ディスプレイの設定」)を検索します。
    2. スライダを 100% に移動するか、または[小 - 100%]を選択して、[適用]をクリックします。
    3. ログアウトして、再度 Windows にログインします。
  • 画面の解像度を下げる:
    1. [スタート]メニューで「ディスプレイ」(または「ディスプレイの設定」)を検索します。
    2. [ディスプレイの詳細設定]をクリックします。
    3. 2000 dpi に近い解像度を選択します。
  • Windows のディスプレイの詳細設定を元に戻す:
    1. [スタート]メニューで「ディスプレイ」(または「ディスプレイの設定」)を検索します。Windows 7 の場合、デスクトップを右クリックし、[個人設定] > [ウィンドウの色] > [デザインの詳細設定]に移動します。
    2. それぞれのメニュー項目をクリックし、選択したフォント サイズが 9 で太字が解除されていることを確認します。
  • AutoCAD DPI スケーリングを無効にする:
    1. AutoCAD の起動ショートカット アイコンまたは acad.exe プログラム ファイルを右クリックし、[プロパティ]を選択します。
    2. [互換性]タブで、次のいずれかのオプションを有効にします。
      1. [高 DPI 設定では画面のスケーリングを無効にする]をオンにします。
      2. [高 DPI 設定の変更]をクリックし、高い DPI スケールの動作を上書きします。[拡大縮小の実行元:]をオンにして、[システム]を選択します。

MacOS の場合

  1. アップル メニューから、[システム環境設定]を選択します。
  2. [ディスプレイ]をクリックします。
  3. [解像度]を[変更]に設定します。
  4. 2000 dpi に近い解像度を選択します。

製品:

AutoCAD for Mac; AutoCAD 製品; AutoCAD LT for Mac;


この情報は役に立ちましたか?


サポートが必要な場合は、Autodesk Assistant にお問い合わせください!

Assistant が回答を見つけたり、担当者に連絡するお手伝いをします。


オートデスクではどのようなサポートが提供されますか?

ご利用可能なサポートの種類は、サブスクリプションのプランによって異なります。現在のプランでご利用可能なサポート レベルをご確認ください。

サポート レベルを確認