「Plug-in Assembly Load Error.The assembly "Autodesk.Max.Wrappers.dll" encountered an error while loading." when starting 3ds Max

Autodesk Support

2023年10月8日


対象となる製品とバージョン


問題:

3ds Max を起動すると、次のようなプラグイン アセンブリ ロード エラー(Autodesk.Max.Wrappers.dll)が発生します。

Plug-in Assembly Load Error
The assembly "Autodesk.Max.Wrappers.dll" encountered an error while loading.

It is possible that this error put the application in a bad state.The application will continue
to run, but we recommend quitting the application, removing the plug-in and restarting.

ファイル: C:\Program Files\Autodesk\3ds Max\\bin\assemblies\Autodesk.Max.Wrappers.dll
Full Error: System.Reflection.TargetInvocationException: Exception has been thrown by
the target of an invocation. ---> System.BadImageFormatException: Could not load file
or assembly 'System.Xml, Version=4.0.0.0, CUlture=neutral,
PublicKeyToken=b77a5c561934e089' or one of the dependencies.The module was
expected to contain an assembly manifest.
at Autodesk.Max.Configuration.Load()
at Autodesk.Max.Manager.Initialize()
at Autodesk.Max.Manager.AssemblyMain()
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle.InvokeMethod(Oject target, Object[] arguments,
Signature sig, Boolean constructor)...
 

ユーザが追加したイメージ

注: プラグイン アセンブリ ロード エラーに示されるメッセージおよびコンポーネントはインストールによって異なります。

原因:

このエラーには次の原因が考えられますが、これらに限りません。
  • 3ds Max のインストールの破損。
  • 現在インストールされている Microsoft .NET Framework との競合。
  • Windows プログラムのファイアウォールおよび権限
  • Windows 更新プログラム。
  • クリーン アンインストールの実行によるアンインストールおよび再インストール。

解決策:

ソリューションには次のいずれか、または複数の組み合わせが必要になる場合があります。


すべての .NET コンポーネントをアンインストールします。

これらのコンポーネントを削除するには、「Microsoft .NET Framework を削除し、再インストールする方法」の手順に従います。

Microsoft ダウンロード センターの情報を参照してください 。



システム変数 PATH を追加または編集する

Windows でシステム変数 PATH を追加または編集するには、次の手順に従います。
  1. Windows の[スタート]で、「コントロール パネル」と入力します。
  2. コントロール パネルの設定を[表示方法: 小さいアイコン] (または大きいアイコン)に変更します。
  3. [システム]を選択します。
  4. [システムの詳細設定]リンクをクリックします。
  5. [詳細設定]タブで[環境変数]ボタンをクリックします。
  6. [システム環境変数]セクションで PATH 環境変数を探して選択します。
  7. [編集]をクリックします。PATH 環境変数がない場合は、[新規]をクリックします。
  8. [システム変数の編集] (または[新しいシステム変数])ウィンドウで次の行を追加します。
C:\Program Files\Autodesk\3ds Max \
  1. コンピュータを再起動してこの問題が解決されるか確認します。



Windows Defender プログラムの除外を追加します。

Windows Defender で 3ds Max の除外を追加するには、Microsoft から提供されている「Windows セキュリティに除外を追加する」の手順に従います。



Windows Defender リアルタイム保護をオフにします。

除外の追加が機能しない場合は、Defender のリアルタイムのスキャナを一時的に無効にして、3ds Max の起動に影響があるか確認します。
複数のプラグイン アセンブリ ロード エラーが表示される場合や、プログラム起動時に他のエラー メッセージが表示される場合は、3ds Max のクリーン アンインストールを実行してから再インストールしてください。

このプロセスによって、次の項目が削除されます。
  • Core 3ds Max インストール コンポーネント
  • TEMP ファイル
  • 残りのファイルとフォルダ
  • 破損した Windows レジストリ キー
  • ライセンス ファイル(ライセンスの問題に該当する場合)



Max.Wrapper.dll ファイルを置き換える

  1. 3d Max をインストールして正常に動作している別のコンピュータの C:\Program Files\Autodesk\3ds Max 20XX\bin\assemblies から Max.Wrapper.dll ファイルをコピーします。このファイルはインストーラ ファイル(C:\Autodesk\3ds Max 20XX\x64\max\ADSK\Max20XX\bin\assemblies)にもあります。
  2. 影響を受けたコンピュータの C:\Program Files\Autodesk\3ds Max 20XX\bin\assemblies に Max.Wrapper.dll ファイルを再配置します。
  3. 3ds Max を再起動して結果を確認します。


クリーン アンインストールを実行し、3ds Max を再インストールします。

上記のいずれによっても問題が解決しない場合は、ここに記載されている手順に従って 3ds Max を削除し、再インストールしてください。
Windows でオートデスク製品のクリーン アンインストールを実行する方法
 

製品:

3ds Max;


この情報は役に立ちましたか?


サポートが必要な場合は、Autodesk Assistant にお問い合わせください!

Assistant が回答を見つけたり、担当者に連絡するお手伝いをします。


オートデスクではどのようなサポートが提供されますか?

ご利用可能なサポートの種類は、サブスクリプションのプランによって異なります。現在のプランでご利用可能なサポート レベルをご確認ください。

サポート レベルを確認